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qutemx ' OpenAltaRica - Example

A (Simple) Water Supply System

Pump P
Source S ump

Tank T

WHAT Feel the tank

HOW  Move the water from the source S to the tank T by
means of a pump P
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A (Simple) Water Supply System

.—'7 A. To design your model

Pump P

Source S

Tank T
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SLISTBW'X ‘ OpenAltaRica - Example
y A (Simple) Water Supply System

.—'7 A. To design your model

Pump P 1. Create a new project into the AltaRicaWizard:
a. ‘File’->'New File or Project’->’New Project’;
b. ‘SimpleWaterSupplySystem’ -> ‘OK’.

Source S

Tank T

Projects g x

ﬁ SimpleWaterSupplySystem
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qutemx ‘ OpenAltaRica - Example
A (Simple) Water Supply System

H A. To design your model
2. Create a new AltaRica 3.0 model:

Pump P
ouree s a. Right-click on the project ‘SimpleWaterSupplySystem’;
b. ‘Add new file to “SimpleWaterSupplySystem™;
Tank T C. You can create a new folder (e.g. ‘ARModels’);
d. ‘SimpleWaterSupplySystem.alt’ -> ‘Save’.
('3" AltaRicaWizard Editor BN
Errlej % ect @Too‘rk wg:jaw Help

Projects B X|| smplewaterSupplySystem.alt [£J ‘
- ﬁ SimpleWaterSupplySystem
4 ARModels
& SimpleWaterSupplySystem.alt

Application Output
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OpenAltaRica - Example

A (Simple) Water Supply System

A. To design your model
Pump P 3. Design your AltaRica 3.0 model.

Source S

Tank T

The source and the pump are repairable components
=> a3 generic class representing repairable components

class RepairableComponent
Boolean working (init = true);
parameter Real lambda = 0.0001;
parameter Real mu = 0.01;
event failure (delay = exponential (lambda)) ;
event repair (delay = exponential (mu)) ;

transition
failure: working -> working := false;
repair: not working -> working := true;

end
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OpenAltaRica - Example
A (Simple) Water Supply System

A. To design your model
Pump P 3. Design your AltaRica 3.0 model.

Source S
class RepairableComponent
Boolean working (init = true);
Tank T parameter Real lambda = 0.0001;
parameter Real mu = 0.01;
event failure (delay = exponential (lambda));
event repair (delay = exponential (mu))
transition
failure: working -> working := false;
repair: not working -> working := true;
end
class Source
extends RepairableComponent; class Pump
<:::> Boolean output (reset = false); extends RepairableComponent;
assertion Boolean input, output (reset = false);
output := if working then true else false; <:::> assertion
end output := if working then input else false;
end

block SimpleWaterSupplySystem
Source S;

Pump P;
block Tank

Boolean input (reset = false);

end

assertion
P.input := S.output;
Tank.input := P.output;

end
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A (Simple) Water Supply System

A. To design your model
Pump P 3. Design your AltaRica 3.0 model.

Source S

Add an observer providing information about the input

flow of the tank. There is no input flow to the tank if:
the value of the flow variable ‘input’ of the tank
‘Tank’ is equal to ‘false’.

Tank T

block SimpleWaterSupplySystem
Source S;
Pump P;
block Tank
Boolean input (reset = false);
end
assertion
P.input := S.output;
Tank.input := P.output;
[ observer Boolean TE tankIsNotSupplied = Tank.input == false;]
end
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B. To check and compile the model

Source S Pump P

Tank T
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OpenAltaRica - Example
A (Simple) Water Supply System

B. To check and compile the model

Pump Launch the AltaRica 3.0 compiler:
a. Click on ‘Tool’ -> ‘Flattening’;
b. You can create a new output folder (e.g. ‘GTSModels’);
c. Results are printed into the ‘Application Output’ part. A
new file is created into the output folder
(e.g. ‘GTSModels’).

r
2P AltaRicaWizard Editor [E=E IR

Source S

Tank T

File Edit Project Tool Window Help
DB DxB
Projects B X | smpleWatersupplySystem.alt (£
a ﬁ SimpleWaterSupplySystem 11 end
ARModels ii . .
class Source
5 SimpleWaterSupplySystem.zlt 14 extends RepairableComponent;
GTSModels 15 Boolean ocutput (reset = false):
& SimpleWaterSupplySystem.gts 16 assertion
17 output := if working then true else false;
18 end
19 (7
20 class Pump
21 extends RepairableComponent;
22 Boolean input, output (reset = false);
23 assertion
24 output := if working then input else false;:
25 end
26
27 block SimpleWaterSupplySystem
28 Source 5:
29 Pump F:
30 block Tank
31 Boolean input (reset = false):
32 end
33 assertion
34 P.input := S.output;
35 Tank.input := P.output;
36
a7 observer Boolean tankIsNotSupplied = Tank.input == false;
38
39 end
40
Application Output -]

Flatten AltaRica Model: CK.

Generate GIS Model: OK.

Compile AltaRica model: CK

gtstck version 1.0.2: GIS type-checker

[ e [
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A (Simple) Water Supply System

C. To simulate the model

Source S Pump P

Tank T
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OpenAltaRica - Example
A (Simple) Water Supply System

C. To simulate the model

Pump P 1. Launch the stepwise simulator:

a. Click on ‘Tool’ -> ‘Stepwise Simulation’;

b. Click on ‘Next’ for the flattening part (it compiles the
model if it has been modified) -> Click on ‘Next’ for the
‘Stepwise Simulation’ part;

c. A new window opens.

Source S

Tank T

g B
29 AltaRicaWizard Stepper [
File Window Help
Selection & X | Tree View Stepper Output Sequence [
Show varia bles Elegent lalug
[7] show even 5 4 B SimpleWaterSupplySystem
4 P
[T show parameters B . inout N
inpuf
Show transitions . output true
Show obeervers . working true
[T failure [0] fireable
T eepartl
aBs
. output true
. working true
BT failure[2] fireable
. repair [3]
4 B Tank
. input true
. tanklsMotSupplied false
Contral H X
Comman d
| ¥ Restart | [« Backirack| [ > apply | [ Exit
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OpenAltaRica - Example

A (Simple) Water Supply System

C. To simulate the model
2. Launch commands to perform experiments:

Pump P
Source 5 .
+ Select elements you want to see (variables, events, etc.);
» Click on fireable transitions to perform a simulation;
Tank T * You can backtrack or restart to a new simulation;
€
* You can run other commands and see results onto the ‘Stepper
’ 6 ) H ‘ ) H
Output’ part (type ‘help’ and click on ‘Apply’ to see available
commands).
r N B
%" AltaRicaWizard Stepper [E=REEn ) %" AltaRicaWizard Stepper [E=EEE )
File Window Help File Window Help
Selection 8 X || TreeView | Stepper Output Sequence 8 x Selection & x Stepper Output Sequence & x
P.failure [0] - P failure [0]
Show variables Element Value S.failure [2] Show variables ;ﬁn:;ﬁ:Eﬁ?gj%ﬁ?é?lﬁysﬂtem‘rGTSMUdEISJ 0 S.failure [2]
[F Show events 4 ? SHimsleWaterSupplySystem S.repair [3] [ show events ;::J;:\ﬂﬂt:fﬁ;;:it:ﬁjaf%ue\opmenthR:Nndalsf I S.repair 3]
imulati d
[] show parameters . input wue [] show parameters 2;";55‘:;;;‘3;?
show transitions show transitions
B ocutput false Available commands:
Show observers . working false Show observers
B e e, e
- g:zt E(anablesl? Dm-lpnnteﬁ?am::rlab\es anndmthzl‘r values,
. repair (1] fireable print o(bservers)? print the observers and their values.
4 B S print tr{ansitions)? print the transitions fireable in the '
= DUtiUt 3 mp;:?:\;?m%;}'i print the execution history. =
t fire <indk fire th iti ber <index:.
b . fre cname> fre e baraiton rames <rames.
. failure [2] iz back cancel the last transition firing.
. repair [3] restart restart the simulation.
4+ B Tank echo <aString> print <aString> (it can contain spaces).
.an set {no)? trace turn on/off the trace mode.
t {no)? di i ff the d de.
. tank‘]’;‘:.ll:tSupp\ied ::‘: ::t gl]:ge ;iplo?rﬁalladuaﬂoed> " onﬁt’:um ﬂeﬂa ‘;ﬂ;z g,ﬂ:rmal or
Tl d.
aq;j?}? quit.
GTSStepSim = L
Control g X Control g x
Command: Command:
4 Restart | [ 4 Backirack| [ » appy | [ Bt 4 Restart | [ 4 Backirack| [ » appy | [ Bt
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D. To generate and study a fault tree

Source S Pump P

Tank T
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A (Simple) Water Supply System

D. To generate and study a fault tree

1. We consider the top event defined by the observer
named ‘TE_tankIlsNotSupplied’ and meaning “There
IS no input flow to the tank”

Source S Pump P

Tank T

block SimpleWaterSupplySystem
Source S;
Pump P;
block Tank
Boolean input (reset = false);
end
assertion
P.input := S.output;
Tank.input := P.output;
[ observer Boolean TE tankIsNotSupplied = Tank.input == false;]
end
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Syst MmX ‘ OpenAltaRica - Example
A (Simple) Water Supply System

D. To generate a fault tree

Pump P 2. Launch the compiler to fault trees and analyze the

generated fault tree:

a. Click on ‘Tool’ -> ‘Compilation into Fault Tree’;

b. Click on ‘Next’ for the flattening part (it compiles the
model if it has been modified) -> Click on ‘Next’ for the
‘Compilation into Fault Tree’ part;

c. Select the name of the generated fault tree (you can
create a new output folder: e.g. ‘FaultTrees’) -> click on
the case ‘Launch Fault Tree Assessment’ and select the
top event you want to observer (‘TE_tankisNotSupplied’
with the value ‘true’) -> ‘Next’

A new window opens

d. Define the XFTA command file (into the created output

folder e.g. ‘FaultTrees’) and select features you want to
compute (only orders of minimal cutsets with results into
the file ‘FaultTrees/Results.txt’) -> click on ‘Create’;

e. Into the ‘Calculations’ part, click on ‘Launch’.

Source S

Tank T
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OpenAltaRica - Example

A (Simple) Water Supply System

D. To generate a fault tree

oo e Pump P 2. Open results:

a. Click on ‘File’ -> ‘Open File or Project’ -> ‘Open File’;
b. Select the file of results ‘FaultTrees/Results.txt’;

s B
Tank T 2 AltaRicaWizard Editor [E=SEER
File Edit Project Teoel Window Help
Projects g x | simpleWaterSupplySystem.alt [ | | Resuilts, txt £ ‘
4 | i@ SimpleWaterSupplySystem 1 1 0.583555 0.5 S.failure
- ARModels 2 2 0.583555 0.5 P.failure
) SimpleWaterSupplySystem.alt 3
FaultTrees
= SimpleWaterSupplySystem.o...
GT5Models
] SimpleWaterSupplySystem.gts
Application Output [
#Gates 1
#BE 2
#Modules 2 A
bye -
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A (Simple) Water Supply System

E. To script simulation

Source S Pump P

Tank T
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Source S

Pump P

Tank T

E. To script simulation

1. Create the script file for simulation:

a. Click on ‘File’ -> ‘New File or Project’ -> ‘New File’ (an
untitled file opens);

b. Save this untitled file : click on ‘File’ -> ‘Save File as...’
(you can create a dedicated folder: e.g. ‘Scripts’) and

A (Simple) Water Supply System

save it (e.g. ‘Sequences.seq’);

REM: the dedicated folder and the script file are not listed to the project.

,
%" AltaRicaWizard Editor

m@g

File Edit Project Tool Window Help

DB DXx®

Projects X

it | Sequences.seq @ |

4 i@ SimpleWaterSupplySystem
4 | ARModels
(s SimpleWaterSupplySystem.alt
FaultTrees
= SimpleWaterSupplySystem.o...
4 | GTSModels
& SimpleWaterSupplySystem.gts

Application Output
0 type error|(

=)
0 type warning(s)
bye
1. GISModels/SimpleWaterSupplySystem.gts: GI5 loadsd
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OpenAltaRica - Example
A (Simple) Water Supply System

E. To script simulation

Pump P 2. Edit the script file for simulation:

a. Enter directly commands into this script file;

b. Launch the stepwise simulator and select the ‘Stepper
Output’ part;

c. Type the command ‘run’ with the path to the script file
(‘run ./Scripts/Sequences.seq’)

Source S

Tank T

- 3
%% AltaRicaWizard Stepper (B>

File Window Help

Selection g x Stepper Output Sequence 8 X

C:/DataMB/OpenAltaRica/OARPIatforms /OARPIatform-winG4-Custom, Tools/
Shaw varizbles ]
Show events Simple\WaterSupp Vater ySystem.gts
O owd C:/Da EMBJUpe \AltaRica/Development/AR 3Models/
[T] show parameters SimpleWatersupplySystem
simulation started
Show transitions GTSStepSim >

GTSStepSim > fire P failure
GTSStepSim = fire P.repair
GT35tepSim »>

Fireable transition(s):
[0] P.failure (delay = exponential{ 0.0001))
[2] S.failure (delay = exponential{ 0.0001))
GTSS5tepSim > >

Show observers

Control [

ol Restart | [ 4 Backtrack| | ® apply | [ EBxit |
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CONTACTS

The OpenAltaRica project
www.openaltarica.fr

contact.oar@irt-systemx.fr

www.irt-systemx.fr
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